In acest articol vom discuta despre cateva topic-uri introductive despre Switch (incluse in modulul de CCNA 2). Vei afla foarte multe lucruri interesante: ce este un switch (scopul acestuia in retea, cum transmite traficul de la un dispozitiv la altul, cum poate impartii o retea fizica in mai multe retele logice, si multe, multe alte subiecte interesante). Hai sa incepem !

Ce este un Switch ? 

Switch-ul este un echipament de retea care functioneaza la nivelul 2 al modelului OSI. Scopul acestuia este de a conecta mai multe device-uri (PC-uri, Laptop-uri, Servere, Imprimante, etc.) in aceeasi retea locala (LAN). Acest echipament contine mai multe port-uri (24 sau 48, depinde de model) care ii permit sa faca legatura in retea.

ce este un switch si cum functioneaza un switch cisco
Figura 1

Marea majoritate a Switch-urilor din ziua de astazi folosesc tehnologia Ethernet. Unul din motive fiind acela ca ne ofera viteze net superioare (1 Gbps / 10 Gbps / 40 Gbps sau chiar 100 Gbps) fata de tehnologiile existente (Token Ring, FDDI, etc.) pe piata in momentul adoptiei. Un Switch trimite datele de la un dispozitiv la celalalt pe baza adreselor MAC (sursa si destinatie).

Ce legatura are un Switch cu adresele MAC ?

Un Switch trimite datele de la un dispozitiv la celalalt pe baza adreselor MAC (sursa si destinatie).

O adresa MAC reprezinta un mod de identificare unic, al fiecarui device dintr-o retea. Acesta este scrisa, din fabrica, pe placa de retea a fiecarui PC, smartphone, laptop, tableta si are urmatoarea forma:

ce este o adresa mac
Figura 2

Este reprezentata in format hexadecimal, pe 48 de biti (12 caractere, 4 biti fiecare caracter). Primii 24 de biti (00-1B-63) reprezinta partea specifica vendor-ului (ex: Cisco, Apple, Intel etc.), iar urmatorii 24 de biti (84-45-E6) reprezinta partea specifica device-ului, care il identifica in mod unic in retea.

Cum invata si foloseste un Switch adresele MAC ? 

Scopul unui Switch este cel de a interconecta mai multe dispozitive in aceeasi retea locala (LAN). El face asta cu ajutorul adreselor MAC (sursa si destinatie). Adresa MAC destinatie este folosita pentru trimiterea traficului catre o destinatie anume, iar adresa MAC sursa este folosita pentru a memora portul pe care se afla un dispozitiv.

Deci practic, Switch-ul invata despre fiecare device din retea pe baza adresei MAC sursa si ia decizia de a trimite pe un port (spre destinatie) anume pe baza adresei MAC destinatie.

Switch-ul retine in memorie o tabela CAM (Content-Addressable Memory) care descrie ce adresa MAC (sursa) se afla pe un port (altfel spus, face o mapare/asociere adresa MAC sursaport) – exemplu: Adresa MAC X se afla pe portul Fa0/5, Adresa MAC G se afla pe portul Fa0/9.

Porturile sunt notate diferit, in functie de viteza maxima:

  • FastEthernet – 100Mbps ( aka. Fa0/1 … Fa0/24 )
  • GigabitEthernet – 1000Mbps ( aka Gi0/1 … Gi0/24 )

Astfel pe masura ce device-urile trimit trafic in retea, Switch-ul va invata adresele (MAC) lor sursa si le va asocia cu porturile de pe care provin (portul la care e conectat device-ul – ex: Fa0/1, Fa0/10 sau Gi0/4 etc.)

Pentru a afla mai multe despre ce este un Switch si modul in care functioneaza acesta, urmareste clip-ul de mai jos:

2) Ce este un VLAN ?

Inveti cum functioneaza VLAN-urile si care e rolul lor in retelele LAN

VLAN-urile (Virtual Local Area Network) ne permit sa separam (din punct de vedere logic) mai multe device-uri (PC-uri, Laptop-uri) conectate la acelasi Switch. Acestea sunt folosite peste tot:

#Ex1: Retea Wireless Guest si Internal; provin de la acelasi Router Wi-Fi dar sunt separate din punct de vedere logic, adica nu poti avea acces din Guest in Internal si nici din Internal in Guest)

#Ex2: in toate companiile medii si mari unde se doreste o separare a traficului din mai multe departamente (exemplu: departamentul de IT (ex: VLAN 45) nu va putea accesa toate resursele din departamentul de Marketing (ex: VLAN 91))

Un VLAN = O Retea = Un Domeniu de Broadcast

Asadar un VLAN reprezinta o retea. Daca alegem sa creeam 2 VLAN-uri, inseamna ca vom avea 2 retele diferite (asadar si 2 domenii de Broadcast).

VLAN-urile sunt folosite peste tot in marile companii. Da-mi voie sa-ti dau cateva exemple:

#Ex1: Reteaua Wireless Guest si Internal; provin de la acelasi Router Wireless, dar sunt separate din punct de vedere logic. Asta inseamna ca, by default, nu poti avea acces din reteaua Guest in reteaua Internal si nici invers.

NOTA: Deci astfel obtinem o separare dpvd. logic care duce la segmentare si la o crestere a nivelului de securitate din retea.

#Ex2: in toate companiile medii si mari unde se doreste o separare dispozitivelor pe departamentele companiei (exemplu: departamentul IT (ex: VLAN 45) nu va putea accesa toate resursele din departamentul Marketing (ex: VLAN 91))

NOTA: pentru a identifica diferite departamente, VLAN-urile folosesc un ID (un numar de identificare) unic caruia ii poate fi asociat un nume (pentru identificarea mult mai usoara).

Astfel, ID-ul unui VLAN poate fi in urmatoarele categorii:

  • Standard VLAN ID – 1 – 1005
  • Extended VLAN ID – 1006 – 4094

Dupa cum poti vedea exista si un range extended de ID-uri care a fost adaugat ulterior, dupa crearea standardului pentru VLAN-uri, scopul acestui range fiind pentru extinderea numarului total de VLAN-uri care pot exista pe un Switch cat si pentru folosirea aplicatilor de rutare pe Switch-uri de nivelul 3.

Inainte de a merge mai departe vreau sa mentionez faptul ca tehnologia VLAN-ul este un standard in industrie si este identificata prin IEEE 802.1q. Asta face ca tehnologia sa fie disponibila pe toate echipamentele de retea (a vendorilor precum Juniper, Huawei, HP etc.) si nu doar pe echipamentele Cisco.

ce este un vlan si cum functioneaza un vlan dintr-o retea lan
Figura 3

Iata in figura 3 o reprezentare mai clara a PC-urilor care pot comunica intre ele. Astfel, dupa cum poti sa vezi, doar PC-urile din acelasi VLAN pot comunica intre ele. 

Toate echipamentele sunt conectate fizic la acelasi Switch, dar dpvd. logic ele sunt separate. De ce? Pentru ca Switch-ul adauga un tag (eticheta) care specific clar faptul ca doar echipamentele care au acelasi tag (aka. VLAN ID) pot comunica intre ele (in acest scenariu, doar PC-urile din cercul verde, respectiv cele din cercul rosu).

ce este un vlan si cum functioneaza un vlan
Figura 4

Beneficiile VLAN-urilor:

  1. Securitate – separarea retelelor la nivel logic
  2. Design mai bun – impartirea unei companii in departamente (fiecare departament reprezentand cate un VLAN (Retea))
  3. Cresterea Performantei
  4. Scalabilitate – se pot adauga foarte usor alte VLAN-uri fara a impacta fluxul retelei

Acestea sunt reprezentate printr-un ID (un numar de la 1 – 4094). Pe Switch-urile Cisco exista cateva ID rezervate, care nu pot fi utilizate, acestea fiind (1, 1002 – 1005):

ce este un switch si ce este un vlan
Figura 5

Pentru a afla mai multe despre VLAN-uri si cum functioneaza aceastea te invit sa urmaresti tutorialul de mai jos:

VLAN-urile se configureaza pe Switch-uri si se asigneaza pe porturile acestora. Porturile Switch-urilor pot fi configurate in 2 moduri:

  • Access – permite trecerea UNUI Singur VLAN
  • Trunk – permite trecerea mai multor VLAN-uri

Porturile de tip Access le configuram atunci cand la celalalt capat se afla un end-device (PC, Laptop, Server etc.).

Porturile de tip Trunk le configuram atunci cand la celalalt capat se afla un Switch, deoarece dorim sa permitem trecerea mai multor VLAN-uri prin si intre acestea.

Spre exemplu, daca interfata Trunk dintre SW1 si SW2 (din figura 6, de mai jos) ar fi avut configurata doar VLAN-ul 10, atunci SW1 nu ar fi putut sa trimita trafic destinat VLAN-ului 20 catre PC-ul conectat la SW2. De aceea este foarte important ca in momentul in care facem setarile unui port in Trunk sa verificam de mai multe ori daca am inclus toate VLAN-urile.

3) Configurarea VLAN-urilor pe Switch-uri

Inveti cum sa configurezi VLAN-urile pe Switch-uri Cisco

Sa presupunem ca avem urmatoarea retea formata din 2 Switch-uri, 4 PC-uri si 2 VLAN-uri (10, respectiv 20):

ce este un vlan, interfata trunk si interfata access
Figura 6

2 dintre aceste PC-uri se afla in VLAN-ul 10, iar celelalte 2 se afla in VLAN-ul 20. Pentru a configura un VLAN pe Switch, trebuie sa urmam urmatorii pasi (din config terminal):

Switch> enable
Switch# configure terminal
Switch(config)# vlan 10
Switch(config-vlan)# name IT
Switch(config)# vlan 20
Switch(config-vlan)# name HR

In acest stadiu, avem VLAN-urile create si le-am asignat un nume (IT pentru VLAN-ul 10 si HR pentru VLAN-ul 20). Mergand mai departe trebuie sa setam aceste VLAN-uri pe interfetele dispozitivelor conectate la Switch.
NOTA: aceste VLAN-uri se configureaza pe FIECARE Switch din retea (SW1 si SW2)

3.1) Configurare Interfata Access

O interfata Access permite trecerea traficului dintr-un SINGUR VLAN (in cazul nostru 10 sau 20) prin ea. Aceasta va fi configurata pe legatura dintre Switchuri si PC-uri in urmatorul mod:

a) In primul rand vom configura interfata FastEthernet 0/1 ca fiind Access pentru VLAN-ul 10:

Switch(config)# interface fa0/1
Switch(config-if)# switchport mode access
Switch(config-if)# switchport access vlan 10

b) In al doilea rand, interfata FastEthernet 0/2 o vom seta pentru VLAN-ul 20, tot in modul Access:

Switch(config)# interface fa0/2
Switch(config-if)# switchport mode access
Switch(config-if)# switchport access vlan 20

Pentru a vedea mai in detaliu cum configurezi un VLAN pe un switch Cisco, te invit sa urmaresti tutorialul de mai jos:

3.2) Configurare Interfata Trunk

O interfata Trunk permite trecerea traficului din mai multe VLAN-uri (in cazul nostru 10 si 20) prin ea. Aceasta va fi configurata pe legatura dintre Switchuri in urmatorul mod (dupa cum poti sa vezi si in imaginea 6, de mai sus):

Switch(config)# interface fa0/24
Switch(config-if)# switchport mode trunk
Switch(config-if)# switchport trunk allowed vlan 10,20

Pana in acest moment am configurat pe cele 2 echipamente de retea, VLAN-urile 10 si 20, am setat porturile la care sunt conectate calculatoarele, in modul Access, am adaugat fiecare PC in VLAN-ul sau, iar la sfarsit am configurat interfata dintre Switch ca fiind Trunk.

Acum, PC-urile din acelasi VLAN (10 – 10) vor putea comunica, iar cele aflate in VLAN-uri diferite nu vor putea comunica (10 – 20).

Pune in Practica – Exerseaza, exerseaza !

Repetitia este mama invataturii, spunea un proverb romanesc, asa ca te las cu acest exercitiu. Spor !

Descarca Topologia in Packet Tracer de AICI.

Daca nu ai instalat Cisco Packet Tracer atunci in gasesti AICI. (versiunea 6.2)

Iti multumesc pentru interesul si atentia acordata acestui articol despre ce este un Switch si cum putem configura un VLAN si interfetele Trunk sau Access.


Daca esti interesat sa inveti mai multe despre Retele de Calculatoare, atunci iti recomand cartea mea “Introducere in Retele de Calculatoare”, care este #1 Best-Seller pe Amazon.

Notiunile explicate in aceasta carte te vor ajuta extrem de mult sa intelegi atat elementele teoretice cat si cele practice care au de a face cu retelele de calculatoare, internetul si cu configurarea echipamentelor Cisco. Click AICI pentru a afla mai multe.

Ramon Nastase

Eu sunt Ramon, am 25 de ani si sunt Pasionat de IT (Retelistica, Programare, Securitate, Tehnologie) si Training. Misiunea mea este sa te ajut pe tine sa-ti atingi potentialul maxim in cariera ta din domeniul IT. Cu acest gand in minte din 2017 pana in prezent, am construit o comunitate de peste 70.000 de persoane pasionate de IT si de invatare continua. Te invit sa citesti articolele de pe acest blog si sa urmaresti celelalte materiale educative de mai jos 👇
Summary
Review Date
Reviewed Item
Ce este un Switch si cum functioneaza un VLAN cu un port Trunk ?
Author Rating
51star1star1star1star1star