Redundanta in LAN pe Switch-uri cu Etherchannel | Invata Retelistica #16

ce este etherchannel si cum functioneaza

      In acest articol incepem discutia despre Redundanta in Retele Locale (LAN) pe Switch-uri. Mai exact vom afla ce este EtherChannel, cum il folosim si cum il putem configura pe Switch-urile Cisco. Hai sa incepem !

Redundanta in LAN pentru Switch-uri

      In articolul precedent am vorbit despre STP si cum ne poate ajuta el sa scapam de buclele dintr-o retea locala. Ce se intampla, in momentul in care intre 2 Switch-uri avem conectate 2 sau mai multe link-uri (asa cum poti vedea in figura de mai jos):

ce este etherchannel si cum blocheaza stp un portEste evident ca intervine Spanning Tree Protocol si blocheaza una dintre cele 2 legaturi ! De exemplu, daca una dintre cele 2 link-uri va fi blocata,  vom folosi doar jumatate din latimea de banda pe care o avem disponibila (in loc de 2 x 10Gbps, doar 1 x 10Gbps).ce este etherchannel si cum il configurez pe switch cisco

Astfel, (asa cum poti vedea si in figura de mai sus) daca avem 2 link-uri de 10 Gbps, latimea de banda totala (NU viteza !)  va fi de 2 * 10Gbps = 20Gbps BW.

De ce nu creste viteza ?

       Haide sa luam urmatorul exemplu: Pe o autostrada din Romania, viteza maxima este de 130km/h, iar aceasta contine 2 benzi.

Ce se va intampla daca se largeste aceasta autostrada la 3 benzi ? Va creste cumva viteza ? Nu, viteza nu va creste, ci va creste numarul total de masini care pot circula in acelasi timp pe autostrada. Exact asta se intampla si cand formam un EtherChannel din 2 sau mai multe link-uri.

2 * 10Gbps -> viteza maxima va fi de 10 Gbps, iar traficul (latime de banda) total care poate fi trimis va fi de 20 Gbps

Ce este EtherChannel ?

       Etherchannel (Link Aggregation sau Link Bundling) este o tehnologie care ne permite sa folosim 2 sau mai multe link-uri (2, 4 sau 8) intre Switch-uri pentru transmiterea simultana a traficului.
Dupa cum spuneam si mai sus, by default, acest lucru nu este posibil datorita STP-ului care blocheaza aceste link-uri, deoarece se pot forma bucle in retea.

Urmareste tutorialul de mai jos pentru a afla mai multe despre acest subiect:

Cum se formeaza un EtherChannel ?

Link-urile EtherChannel pot fi formate (negociate) in 2 moduri:

  • Manual
  • Dinamic (LACP / PAgP)

        Primul modul de setare al Etherchannel-ului este cel manual, care este extrem de simplu de configurat (pur si simplu pornim la ambele capete/Switch-uri acest mod, iar Etherchannel-ul va fi format). Dezavantajul acestui mod de configurare este troubleshooting-ul.

        In momentul in care se intampla ceva cu link-urile dintre cele 2 Switch-uri, iar Etherchannel-urile esueaza, nu vom primi log-uri/notificari (iar asta face din procesul troubleshooting unul extrem de dificl).

        Al doilea mod de configurare este cel dinamic, unde avem 2 protocoale care se pot ocupa de negocierea “imperecherii link-urilor” (LACP si PAgP). Ambele protocoale fac exact acelasi lucru (negociaza formarea EtherChannel-ului), diferenta dintre ele fiind urmatoarea:

  • PAgP este Cisco proprietary (existent doar pe Switch-uri Cisco) si foloseste starile Desirable/Auto
  • LACP este vendor independent (un standard; oricine il poate folosi) si foloseste starile Active/Passive
Citeste si:  Cum Cresc in Masa Musculara ? | 3 Sfaturi

Avantajul folosirii modului dinamic este clar:

  • Negociere automata
  • Log-uri de informare in caz de eroare
  • Troubleshooting mai simplu

Cum Configuram EtherChannel pe Switch-uri Cisco ?

        Acum ca am aflat ce este EtherChannel si cum functioneaza, propun sa trecem la partea de configurare a acestuia pe Switch-uri. Topologia va fi cea din figura de mai jos si vom incepe cu modul manual (ON):ce este etherchannel si cum il configurez pe switch ciscoIn primul rand, trebuie sa intram pe cele 2 interfete (sau mai multe) – pe care dorim sa le includem in acest Etherchannel – si sa le configuram in modul dorit (in acest caz TRUNK). Atentie interfetele trebuie sa aiba aceeasi configuratie (VLAN, QoS, Security, etc.):

SW1(config)#interface range GigabitEthernet0/11 – 12
SW1(config-if-range)#switchport mode trunk
SW1(config-if-range)#switchport trunk allowed vlan 10,20,30

In al doilea rand avem nevoie de aceasta comanda (pe ambele Switch-uri) pentru setarea modului ON:

SW1(config-if-range)#channel-group 5 mode on

Daca dorim sa configuram un protocol de negociere (LACP sau PAgP):

PAgP (Cisco proprietary)

SW1(config-if-range)#channel-group 5 mode desirable

SW2(config-if-range)#channel-group 5 mode auto

LACP (standard, vendor-independent)

SW1(config-if-range)#channel-group 5 mode active

SW2(config-if-range)#channel-group 5 mode passive

        Acesta a fost modul in care configuram EtherChannel pe un Switch Cisco. Acum PROVOCAREA mea pentru tine este sa descarci laboratorul de mai jos si sa aplici si tu aceste comenzi in Cisco Packet Tracer ! Spor la treaba !

Pune in Practica – Exerseaza, exerseaza !

Repetitia este mama invataturii, spunea un proverb romanesc, asa ca te las cu acest exercitiu. Spor !

Descarca Topologia in Packet Tracer, de AICI.

redundanta in lan pe switch-uri si routere

Daca nu ai instalat Cisco Packet Tracer atunci in gasesti AICI. (versiunea 6.2)

Te Felicit si iti Multumesc 🙂

        Te Felicit pentru ca ai ales sa inveti mai multe si sa devi mai bun si iti multumesc pentru interes si atentia acordata. In acest articol ai aflat ce este EtherChannel, cum functioneaza si cum il poti configura pe Switch-uri Cisco.

Da un SHARE acestui articol si ABONEAZA-TE la canalul de YouTube pentru a fi la curent cu ultimele tutoriale! Conecteaza-te cu mine pe LinkedIn !

Descarca #eBook + “Manual de Comenzi Cisco

ebook gratuit retelistica ramon nastase

 

Summary
Review Date
Reviewed Item
Ce este EtherChannel si cum il folosim pe Switch ? | Invata Retelistica #16
Author Rating
51star1star1star1star1star