In acest articol vom discuta despre modurile in care putem face rutarea intre VLAN-uri. Dupa cum stii din articolul trecut, traficul nu poate trece dintr-un VLAN in celalalt fara existenta unui echipament de nivelul 3 din stiva OSI. In cele ce urmeaza vei putea afla cum poti trimite trafic dintr-un VLAN in celalalt. Hai sa incepem ! 😉

By default, Switch-urile nu stiu sa lucreze cu pachete IP (doar cu adrese MAC), ceea ce inseamna ca acestea nu vor putea face transfer de date (rutare) dintr-un VLAN in celalalt. Invata AICI cum functioneaza Switch-urile sau urmareste video-ul de mai jos:

Datorita faptului mentionat mai sus, Rutarea Inter-VLAN poate avea loc in 3 moduri:

1) Folosind un Router cu atatea interfete cate VLAN-uri exista (acest model nu este unul scalabil, deoarece pe Routere avem un numar limitat de interfete)

cum functioneaza routarea intre vlan pe router cisco cu mai multe interfete legacy

2) Folosind un Router conectat la Switch cu o singura interfata (Trunk) prin care vom permite trecerea mai multor VLAN-uri – acest model se numeste Router-on-a-Stick si este subiectul discutiei de astazi (urmand ca la clip-ul viitor sa vedem cum se poate seta pe router)

cum seteze rutarea intre vlan pe router cisco

3) Folosind un Switch de Nivelul 3 (L3) – capabil sa faca rutare (sa trimita pachete intre VLAN-uri)

cum functioneaza un switch cisco layer 3

        Conceptul de Router-on-a-Stick este unul foarte simplu. Acesta permite trecerea mai multor VLAN-uri printr-o singura interfata (Trunk) conectata intre Router si Switch.
Pe Switch, interfata va fi configurata ca fiind Trunk, iar pe Router se vor creea Sub-Interfete pentru fiecare VLAN in parte.

In acest video poti sa vezi cum implementez/configurez Router-on-a-Stick:

Configurare Rutarea intre VLAN-uri (Router-on-a-Stick)

cum seteze rutarea intre vlan pe router cisco

* Scenariu:

Sa luam scenariul de mai sus. Presupunem ca, recent am creat o companie, pe nume RoaS, care creste foarte repede. La inceput eram organizati intr-un singur departament, dar cum cresterea este foarte rapida, acest design nu mai este unul scalabil si securizat; asa ca ne-am hotarat sa impartim compania in mai multe departamente (IT si Vanzari , deocamdata).

Fiecare dintre aceste departamente va avea un spatiu de adresare propriu (/24) cu IP-urile 10.10.10.0/24 – IT si 10.20.20.0/24 – Vanzari.

Scopul nostru este ca aceste 2 departamente sa poate comunica intre ele. Implicit, ele nu pot vorbi unul cu celalalt deoarece este necesara existenta unui echipament de nivelul 3 (Router sau Switch de Nivelul 3).

Un alt factor, pe care compania noastra trebuie sa il aiba in vedere este costul acestor echipamente. Momentam avem buget doar pentru un Router, deoarece un Switch de Nivelul 3 este mult mai scump.

Asadar, pe langa cost, fiind limitati si de numarul de interfete disponibile pe Router (in general 2-3), solutia pe care o avem la dispozitie pentru a configura Rutarea intre VLAN-uri este Router-on-a-Stick.

Pentru a configura Router-on-a-Stick, trebuie sa setam link-ul care conecteaza Switch-ul la Router, ca fiind Trunk; pe Router trebuie sa pornim interfata fizica si sa configuram atatea subinterfete (ex: Fa0/0.10) cate VLAN-uri avem:

Switch(config)#interface Fa0/24
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk allowed vlan 10,20
Router(config)#interface Fa0/0
Router(config-if)#no shutdown

Acum este momentul sa configuram subinterfetele pentru fiecare VLAN in parte. In scenariul de mai sus, avem 2 VLAN-uri, 10 si 20. Pentru a configura aceste subinterfete pentru fiecare VLAN in parte, trebuie urmati pasii de mai jos:

Router(config)#interface Fa0/0.10
Router(config-if)#encapsulation dot1q 10
Router(config-if)#ip address 10.0.0.1 255.255.255.0
Router(config)#interface Fa0/0.20
Router(config-if)#encapsulation dot1q 20
Router(config-if)#ip address 192.168.0.1 255.255.255.0

Poti urmarii intregul config AICI.

Te Felicit si iti Multumesc 🙂

        Te Felicit pentru ca ai ales sa inveti mai multe si sa devi mai bun si iti multumesc pentru atentia acordata. In acest articol ai aflat ce este o adresa IPv6, cum arata si cum poti seta una.

Da un SHARE acestui articol si ABONEAZA-TE la canalul de YouTube pentru a fi la curent cu ultimele tutoriale! Conecteaza-te cu mine pe LinkedIn !

 

Ramon Nastase

Eu sunt Ramon, am 25 de ani si sunt Pasionat de IT (Retelistica, Programare, Securitate, Tehnologie) si Training. Misiunea mea este sa te ajut pe tine sa-ti atingi potentialul maxim in cariera ta din domeniul IT. Cu acest gand in minte din 2017 pana in prezent, am construit o comunitate de peste 70.000 de persoane pasionate de IT si de invatare continua. Te invit sa citesti articolele de pe acest blog si sa urmaresti celelalte materiale educative de mai jos 👇
Summary
Review Date
Reviewed Item
Rutarea intre VLAN-uri cu Router-on-a-Stick | Invata Retelistica #4
Author Rating
51star1star1star1star1star